#21  
Old 19th August 2016, 02:10 AM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 615
Default

Quote:
Originally Posted by rgg View Post
updated 2: i've tried to install it on the laptop and the same dialog box appears.
Quote:
Originally Posted by millansoft View Post
any ideas?
Shot in the dark, but, try installing it to your Users name directory. e.g.
C:\Users\YOURNAME\Project64

Wondering if there is a problem with permissions on Windows 10, not allowing Project64 to write/create the cfg files etc.

Does it change anything?

Edit:
@zilmar
I've just changed the installer script to use the Users directory. Had to go back one level, as the old version of inno used doesn't support Windows 10 path constants.

DefaultDirName={userdocs}\..\Project64 2.3

If the problem on Windows 10 is installing into Program Files, this should fix it...
It might be time to update to the latest inno setup. http://www.jrsoftware.org/isinfo.php
The new version will allow to specify which lines in the script run on specified versions of windows upto windows 10. So you could use program files for OS below windows 8, Users or users program files directory for above windows 8.

Last edited by Frank74; 19th August 2016 at 03:27 AM.
Reply With Quote
  #22  
Old 19th August 2016, 06:59 AM
rgg rgg is offline
Project Supporter
Junior Member
 
Join Date: Aug 2006
Posts: 11
Default

Quote:
Originally Posted by millansoft View Post
Hello,

I have a Windows 10 fresh install, Nvidia GTX750, I5, 8GB ram.
I installed lastest DirectX 9 and Visual C Runtime 2008, and get the following error as seen in the image, any ideas?

Thanks!
i have the same problem. by the moment, no solution.
Reply With Quote
  #23  
Old 19th August 2016, 11:58 AM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 615
Default

Try this answer here.
a-windows-10-fault-with-file-permissions

And maybe do this as well.
Quote:

I have this issue on at least three machines I upgraded to Windows 10, two Windows 8.1 Pro and one Windows 7 Ultimate.

Looking at the particular error folder for my latest problem I see these permissions:

Administrators: Full control
SYSTEM: Full control
HomeUsers: Read & Execute

The owner of the folder is my current Microsoft account signon.

What's got me puzzled is that the current signon on the machine is an administrator, so it would seem to me that the user should have full control of the folder, but that's not the case.

Use the following procedure to fix this as long as you don't reboot your machine:

1 Signon as an administrator on your machine.
2 Navigate to the folder where you're having the problem, in my case D:\users\myname\Documents. Right-click and select Properties from the pop-up menu.
3 Under Properties | Security tab, click the Advanced button, then click "Change" owner on the Advanced Security Settings dialog (if you are already the owner, do this step anyway!), and in the resulting dialog enter whatever you want the owner to be, in my case it's my Microsoft account).
4 Now a new check-box appears labeled "Replace owner on subcontainers and objects"; check it.
5 Also check the box at the bottom "Replace all child object permission entries with inheritable permission entries from this object."
6 Make sure under the Permission entries grid that your current account has Full control (if not Edit or Add your account to be listed with foll control). Finally hit Apply. This may take a while.

If you don't follow the above Advanced procedure and just try to add permissions on the Security tab, you may get errors.
There are literally thousands of posts about this problem of permissions on Windows 10.

Last edited by Frank74; 19th August 2016 at 12:23 PM.
Reply With Quote
  #24  
Old 19th August 2016, 12:26 PM
rgg rgg is offline
Project Supporter
Junior Member
 
Join Date: Aug 2006
Posts: 11
Default problem with pj64 v2.3

finally Works!!!!! Frank74 thank you so much for your time. the last solution (install in user directory) is correct.
Reply With Quote
  #25  
Old 19th August 2016, 12:41 PM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 615
Default

Quote:
Originally Posted by rgg View Post
finally Works!!!!! Frank74 thank you so much for your time. the last solution (install in user directory) is correct.
Hooray!

So you didn't need to alter permissions or disable one drive? You just installed to the Users directory?

If so, I've fixed the installer to install to the Users directory.

I need to try and fix it so it installs to the Users directory for Windows 8, 8,1 and 10. And Program Files for Windows 7 and below. Then I'll do a PR so that zilmar can replace the official download.

My 333rd post!
Reply With Quote
  #26  
Old 19th August 2016, 12:51 PM
rgg rgg is offline
Project Supporter
Junior Member
 
Join Date: Aug 2006
Posts: 11
Default

Quote:
Originally Posted by Frank74 View Post
Hooray!

So you didn't need to alter permissions or disable one drive? You just installed to the Users directory?

If so, I've fixed the installer to install to the Users directory.

I need to try and fix it so it installs to the Users directory for Windows 8, 8,1 and 10. And Program Files for Windows 7 and below. Then I'll do a PR so that zilmar can replace the official download.

My 333rd post!
i've only installed in C:\users\Ruben\ and Works properly. i have not changed anything else. Thanksssss again
Reply With Quote
  #27  
Old 19th August 2016, 07:50 PM
millansoft millansoft is offline
Junior Member
 
Join Date: Aug 2016
Posts: 12
Default

Hello,

I found the same problem in Windows 7 in another machine that I'm using with HyperSpin/RocketLauncher, is it possible to use the new version in another folder like any other emulator?

Thanks!
Reply With Quote
  #28  
Old 19th August 2016, 07:59 PM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 615
Default

Quote:
Originally Posted by millansoft View Post
Hello,

I found the same problem in Windows 7 in another machine that I'm using with HyperSpin/RocketLauncher, is it possible to use the new version in another folder like any other emulator?

Thanks!
Yes, as long as you have full read/write permissions in the folder you run Project64 from.
Reply With Quote
  #29  
Old 20th August 2016, 01:57 AM
Rotnam Rotnam is offline
Junior Member
 
Join Date: Aug 2016
Posts: 1
Default

I tried to fight with the permissions no luck, as soon as I cut&paste the folder under my user it work right away. Not sure yet
Reply With Quote
  #30  
Old 20th August 2016, 02:00 AM
millansoft millansoft is offline
Junior Member
 
Join Date: Aug 2016
Posts: 12
Default

I know that the emulator is wonderful and free, and one can't demand anything about it because would be selfish, I said this before to avoid a misunderstanding, but that a soft can't run in any folder, it's just wrong
Reply With Quote
Reply
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 01:11 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.