#1  
Old 18th May 2014, 11:12 PM
RPGMaster's Avatar
RPGMaster RPGMaster is offline
Alpha Tester
Project Supporter
Super Moderator
 
Join Date: Dec 2013
Posts: 2,008
Default Emulator Crashes

Sometimes when I load a save state, the emulator crashes. This tends to happen more often if you load state right after loading a game. Is it my settings or is the emulator glitched?
  #2  
Old 19th May 2014, 01:41 AM
V1del V1del is offline
Project Supporter
Senior Member
 
Join Date: Feb 2012
Posts: 442
Default

Save states are unreliable and tend to break that's pretty much all there is to it, keep a real save around if you want to do actual gameplay or have multiple states to be guarded against corruption while testing stuff
  #3  
Old 19th May 2014, 06:21 AM
RPGMaster's Avatar
RPGMaster RPGMaster is offline
Alpha Tester
Project Supporter
Super Moderator
 
Join Date: Dec 2013
Posts: 2,008
Default

Oh ok thanks, so it's not just me then lol. I was just mostly wondering if I was using some setting that made save states crash. I'll have to look at the code to see what's wrong.

Edit: I found the cause. It was azimers audio lol... At first I thought the problem was pj64 1.6, but then I looked in visual studios and it said
Code:
First-chance exception at 0x7BDB4B59 in Project64.exe: 0xC0000005: Access violation writing location 0x51A30018.
First-chance exception at 0x005C6806 (AziAudio.dll) in Project64.exe: 0xC0000094: Integer division by zero.
Unhandled exception at 0x005C6806 (AziAudio.dll) in Project64.exe: 0xC0000094: Integer division by zero.
Then I went back and checked to see what plugin I was using on a different emulator and it wasn't Azimer's.

Last edited by RPGMaster; 19th May 2014 at 07:30 AM.
  #4  
Old 19th May 2014, 08:31 AM
RPGMaster's Avatar
RPGMaster RPGMaster is offline
Alpha Tester
Project Supporter
Super Moderator
 
Join Date: Dec 2013
Posts: 2,008
Default

Looks like the issue is still 1.6 specific. So basically using a combination of PJ64 1.6 and Azimer's audio can cause the emulator to crash upon loading a save state.
  #5  
Old 20th May 2014, 10:36 AM
RPGMaster's Avatar
RPGMaster RPGMaster is offline
Alpha Tester
Project Supporter
Super Moderator
 
Join Date: Dec 2013
Posts: 2,008
Default

Well now I don't have to worry about fixing pj64 1.6 since the latest version of Azimers audio works better. I'm guessing something may be wrong with PJ64 1.6's plugin spec because I did not have the crashing issue issue in other versions. Looks like I can't just take other people's word for what plugins to use. Stupid outdated lists -_-.

Are there any other good hle audio plugins?

Edit: Turns out it crashes in other versions too so it's not just 1.6. Good thing 0.60 is out .

Last edited by RPGMaster; 20th May 2014 at 07:37 PM.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 08:04 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.