#21  
Old 30th March 2013, 11:18 PM
xQuarkDS9x's Avatar
xQuarkDS9x xQuarkDS9x is offline
Project Supporter
Junior Member
 
Join Date: Jun 2006
Posts: 10
Default

Quote:
Originally Posted by elbeto57 View Post
Im not been here for a loooooooooooooooong time, so were i can get the 2.0 or newst release?
http://www.pj64-emu.com/site-membership/

Donate $20 US and you can have the latest 2.0.0.xx beta versions to use. Even though I donated way back in 2006 it was worth it then and it's worth it especially today.

I've been using 2.0.0.11 and up to play Ocarina of Time, Majora's mask, and Super Mario Bros 64 and having a blast re-living these old games since my original console died last year.

Oddly enough the only short pause I had that squall_leonhart mentioned when entering menu screens occured when using a high res texture pack from this site in Ocarina of Time when first loaded (afterwards menu screens loaded up right away) but other then that the games have ran smoothly with no major problems in audio or graphics and on my old machine here with a small tweak to Majora's Mask reducing "AI Count Per Byte" from 500 to 100 i even got rid of a small sound issue.

Last edited by xQuarkDS9x; 30th March 2013 at 11:23 PM.
Reply With Quote
  #22  
Old 31st March 2013, 06:15 AM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,894
Default

you have no idea what you're talking about.

compare the games with interpreter and you'll get some idea.
__________________
Xfire Profile | VBA-M | XBCD 0.2.7

CPU:Intel i7 920 @ 3.8(D0), Mainboard:Asus Rampage II Gene, Memory:12GB Corsair Vengeance 1600
Video:EVGA Geforce GTX 680+ 4GB, Sound:Creative XFI Titanium Fatal1ty Pro, Monitor:BenQ G2400WD
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
Reply With Quote
  #23  
Old 3rd April 2013, 05:45 AM
xQuarkDS9x's Avatar
xQuarkDS9x xQuarkDS9x is offline
Project Supporter
Junior Member
 
Join Date: Jun 2006
Posts: 10
Default

Quote:
Originally Posted by squall_leonhart View Post
you have no idea what you're talking about.

compare the games with interpreter and you'll get some idea.
Why is it that after reading plenty of your posts both here and on other forum sites you seem to like complaining constantly about using recompiler instead of interpreter?

All i've done is posted my personal experiences about playing a couple of games. I am aware some games do run better with interpreter still and with various other tweaks to get a game running smoothly but still you practically make it sound like "Recompiler is the devil from hell and should be avoided at all costs" yet even after I tried interpreter and noticed no difference in ocarina of time, I did notice an immediate change in majora's mask when switching start menu screens I had speed issues but the moment i went back to recompiler no issues in those start menu's whatsoever.

How did an alpha tester named dsx! put it recently in another forum thread? http://forum.pj64-emu.com/showthread.php?t=3573&page=2

Quote:
Originally Posted by dsx! View Post
if its so bad, you fucking fix it
I think that says it pretty much. If you think recompiler is so bad like he said then go fix it.
Reply With Quote
  #24  
Old 4th April 2013, 08:34 AM
xQuarkDS9x's Avatar
xQuarkDS9x xQuarkDS9x is offline
Project Supporter
Junior Member
 
Join Date: Jun 2006
Posts: 10
Default

Quote:
Originally Posted by squall_leonhart View Post
you have no idea what you're talking about.

compare the games with interpreter and you'll get some idea.
If you think recompiler is so bad then as one other alpha tester here recently put it on the forums "go fix it yourself".
Reply With Quote
  #25  
Old 4th April 2013, 10:28 AM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,894
Default

already did, and already working with deathdroid to fix more ;D
__________________
Xfire Profile | VBA-M | XBCD 0.2.7

CPU:Intel i7 920 @ 3.8(D0), Mainboard:Asus Rampage II Gene, Memory:12GB Corsair Vengeance 1600
Video:EVGA Geforce GTX 680+ 4GB, Sound:Creative XFI Titanium Fatal1ty Pro, Monitor:BenQ G2400WD
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
Reply With Quote
  #26  
Old 4th April 2013, 12:09 PM
dsx_ dsx_ is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2010
Location: Australia
Posts: 1,105
Default

Quote:
Originally Posted by squall_leonhart View Post
already did, and already working with deathdroid to fix more ;D
wooooooooo
Reply With Quote
  #27  
Old 4th April 2013, 03:27 PM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,894
Default

Turned out that my particular issue wasn't actually a bug as much as it was just better logging detail.

I had Generate Logs enabled and it was creating a 50-100MB cpu output dump during those points which resulted in the execution being stalled heavily.

There is still some difference between the Rec and Interpreter when starting a goldeneye level now, which deathdroid is attempting to look into - the worst parts are the regressions in the b57 version of jabo's d3d that was included..... would've been best to include b56 imo.
__________________
Xfire Profile | VBA-M | XBCD 0.2.7

CPU:Intel i7 920 @ 3.8(D0), Mainboard:Asus Rampage II Gene, Memory:12GB Corsair Vengeance 1600
Video:EVGA Geforce GTX 680+ 4GB, Sound:Creative XFI Titanium Fatal1ty Pro, Monitor:BenQ G2400WD
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
Reply With Quote
Reply
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 11:27 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.