#111  
Old 30th July 2014, 12:10 AM
RPGMaster's Avatar
RPGMaster RPGMaster is offline
Alpha Tester
Project Supporter
Super Moderator
 
Join Date: Dec 2013
Posts: 2,008
Default

I just went and tested PJ64 2.1. It never seems to crash at all. The only issue I've seen on PJ64 2.1 is that message box HatCat showed. I find it ironic that certain plugins are extra buggy on PJ64 2.1 like 1964 Audio and Ziggy's PJ64 RSP.

I do agree on making a new emulator . Or at least fixing a current one. I'm considering back porting some of Mupen64Pluses changes to Mupen64 0.5. Then I'm also trying to fix up 1964 1.1. And now I'm thinking about just using Apollo's source lol. I like having a smaller code base . Not sure which goal to start first.
Reply With Quote
  #112  
Old 30th July 2014, 01:20 AM
Azimer Azimer is offline
Project Supporter
Member
 
Join Date: Dec 2005
Posts: 74
Default

Which plugin are you switching back and forth to and from to get this error? I am not getting the way issue nor am I using wxWidget. It could also be a common error from one of the other plugins too. I do know PJ64 has a serious issue when you hit the x to close the program. Sometimes it ends the process in the middle of DLLs unloading so you will get an unload error. I haven't been able to do anything with that.

Last edited by Azimer; 30th July 2014 at 01:23 AM.
Reply With Quote
  #113  
Old 30th July 2014, 02:15 AM
RPGMaster's Avatar
RPGMaster RPGMaster is offline
Alpha Tester
Project Supporter
Super Moderator
 
Join Date: Dec 2013
Posts: 2,008
Default

I was switching between 0.70 and 0.60 WIP 2. Basically when I go from 0.60 to 0.70 then back to 0.60, it crashes. It may seem silly to do, but I like to compare plugins, so that's how I ran into the issue.

With PJ64 2.1, switching plugins is never an issue.

Well this is interesting. I was testing it with PJ64 1.6, and sometimes it requires me to switch between the 2 plugins many times before it finally crashes.

Are you able to even run PJ64 1.4 Audio Fix Edition with the XAudio version? The emulator just crashes after running the exe.

Lol I always thought it was odd how I'd sometimes get that crash when closing PJ64 1.6 . You have any idea what that message box problem is about? It's kinda weird seeing that pop up when opening the plugin selection menu.
Reply With Quote
  #114  
Old 30th July 2014, 02:57 AM
Azimer Azimer is offline
Project Supporter
Member
 
Join Date: Dec 2005
Posts: 74
Default

I fixed the crash error for XA2 on PJ 1.6 but it's still VERY crashtastic. I don't know if that's my plugin or if it's the emulator. I will have to do some further testing.

I can not get the plugins to crash in 2.1. I will try PJ64 1.4 AFE when I can get a chance. Typically, if it's zilmar's spec, it should work on any emulator.
Reply With Quote
  #115  
Old 30th July 2014, 03:09 AM
RPGMaster's Avatar
RPGMaster RPGMaster is offline
Alpha Tester
Project Supporter
Super Moderator
 
Join Date: Dec 2013
Posts: 2,008
Default

Correction, I can run PJ64 1.4 AFE, but it crashes when I try to run a game.

It's hard to say what the true cause is, but I will say that PJ64 1.6 has a faulty plugin spec implementation.

I did more testing with the DS8 version and still haven't run across any problems.

I just debugged PJ64 1.6 and it's crashing at ShutdownPlugins function, when I constantly switch between plugins. So I suspect there's a problem with CloseDll().

I'll go ahead and look at PJ64 2.1's source to see why that one doesn't have problems when switching plugins.

It sure pays off to compile a bunch of open source emulators! I think it'll be a good experience working with Apollo, once I'm able to compile it .
Reply With Quote
  #116  
Old 30th July 2014, 03:11 AM
Azimer Azimer is offline
Project Supporter
Member
 
Join Date: Dec 2005
Posts: 74
Default

Thanks for the note. I am unable to crash Apollo with my fixed XA2 plugin. I love my emulator <3... I bet with a few fixes it could have been very awesome
Reply With Quote
  #117  
Old 30th July 2014, 03:52 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Yeah, sometime there ought to be a 64-bit emulator supporting the plugin spec with a more accurate attitude. That ought to popularize things better, although dynarec would have to temporarily be removed just to hurry up and have the damn thing.

Regarding the wxWidgets issue, it indeed isn't coming from the audio plugin ... it seems to be controlled by the video plugin I choose. Using OpenGL plugins, like mine, accelerates the wxWidgets message to pop up after a single try of load emulation then config plugins. With DirectX plugins though, like zilmar's Basic CFB and Jabo's Direct3D, you might need to start emulation, options:settings..., end emulation, start emulation, settings..., end emulation, then once more options:settings... to eventually see this message when using azi xaudio2 dll.

Quote:
Originally Posted by Azimer View Post
RSP fake "HLE". I use it as a fallback for when HLE doesn't support the uCode.
Yeah when I realized that "Enable RSP emulation" thing was for forcing LLE audio within the plugin like shunyuan did, I thought maybe it might confuse less people if that was named "Force RSP LLE", since the nature of the algorithm itself is still kinda LLE.

idk, I guess people would follow like a radio options pair, that went something like,
RSP Audio Emulation:
* Low-level, within audio plugin ("Fake HLE")
* Low-level, from RSP emulation plugin
* High-level (LLE faking HLE if unsupported ucode) //default
* High-level (try to always force, throw error if game uses unknown ucode)

Just some imagining.
Reply With Quote
  #118  
Old 30th July 2014, 01:44 PM
Azimer Azimer is offline
Project Supporter
Member
 
Join Date: Dec 2005
Posts: 74
Default

Thinking I will reconsider the who RSP in the audio dll thing anyway. I don't like convoluted options like that or call something HLE when it's not really like Shunyum's plugin. Then I can finish the darn thing quicker. I'd really like to be done by the end of the year so I can move on to new things.
Reply With Quote
  #119  
Old 31st July 2014, 05:57 PM
Azimer Azimer is offline
Project Supporter
Member
 
Join Date: Dec 2005
Posts: 74
Default

Quote:
Originally Posted by RPGMaster View Post
Are you able to even run PJ64 1.4 Audio Fix Edition with the XAudio version? The emulator just crashes after running the exe.
I am with the new build.
Reply With Quote
  #120  
Old 31st July 2014, 06:08 PM
RPGMaster's Avatar
RPGMaster RPGMaster is offline
Alpha Tester
Project Supporter
Super Moderator
 
Join Date: Dec 2013
Posts: 2,008
Default

Quote:
Originally Posted by Azimer View Post
I am with the new build.
Thanks. So the reason it crashed for me was simply because of the gfx plugin I was using (Jabo 1.6). When i changed video plugin, it no longer crashed when loading a game. Kinda odd.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 03:09 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.