Go Back   Project64 Forums > General Discussion > Site News

Reply
 
Thread Tools Display Modes
  #11  
Old 1st April 2013, 06:29 AM
dsx_ dsx_ is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2010
Location: Australia
Posts: 1,105
Default

Quote:
Originally Posted by squall_leonhart View Post
if this is legit, good, means someone can fix the crap out of the mess you made of the recompiler.

though im going with april fools joke right now, since fobbing alpha quality emulators as release quality is a nasty joke
if its so bad, you fix it

Last edited by dsx_; 6th October 2013 at 03:57 PM.
Reply With Quote
  #12  
Old 1st April 2013, 06:38 AM
Mr. DOS Mr. DOS is offline
Junior Member
 
Join Date: Dec 2008
Posts: 4
Default

Quote:
Originally Posted by xQuarkDS9x View Post
I'd say its a crude april fools day joke. Considering that the site was down most of March 31st showing just a "Joomla" CMS logo it does make me wonder if it was legitimate or not.
Maybe, but it's also a functioning copy of the emulator that doesn't require a paid user account to download and use.

I would like to note, though, that:

Code:
> git clone git://pj64-emu.com:8090/project64.development/ project64
Cloning into 'project64'...
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
...does not build confidence in ones' open source release.
Reply With Quote
  #13  
Old 1st April 2013, 06:46 AM
zilmar zilmar is offline
Core Team
Alpha Tester
Project Supporter
Administrator
 
Join Date: Jun 2005
Posts: 987
Default

Quote:
Originally Posted by Mr. DOS View Post
Code:
> git clone git://pj64-emu.com:8090/project64.development/ project64
Cloning into 'project64'...
fatal: Could not read from remote repository.
...does not build confidence in ones' open source release.
try
Code:
> git clone http://pj64-emu.com:8090/project64.development/ project64
Reply With Quote
  #14  
Old 1st April 2013, 06:47 AM
Mr. DOS Mr. DOS is offline
Junior Member
 
Join Date: Dec 2008
Posts: 4
Default

Quote:
Originally Posted by zilmar View Post
try
Code:
> git clone http://pj64-emu.com:8090/project64.development/ project64
Code:
> git clone http://pj64-emu.com:8090/project64.development/ project64 -v
Cloning into 'project64'...
error: Connection time-out while accessing http://pj64-emu.com:8090/project64.development/info/refs?service=git-upload-pack
fatal: HTTP request failed
I'll try again later. Glad to hear it's just a problem on my end and not the release being a hoax, though
Reply With Quote
  #15  
Old 1st April 2013, 06:56 AM
zilmar zilmar is offline
Core Team
Alpha Tester
Project Supporter
Administrator
 
Join Date: Jun 2005
Posts: 987
Default

i found a thread that some one had with a different repository.

Quote:
You'll need to upgrade your git client to be at least version 1.6.6.

That error is caused by older versions of git not understanding the
Git Smart HTTP protocol
not sure if it applies to you
Reply With Quote
  #16  
Old 1st April 2013, 07:16 AM
Mr. DOS Mr. DOS is offline
Junior Member
 
Join Date: Dec 2008
Posts: 4
Default

Quote:
Originally Posted by zilmar View Post
not sure if it applies to you
Code:
> git --version
git version 1.8.0.msysgit.0
Doesn't look like it should, but my Git binary comes from GitHub for Windows, so the actual problem may be related not just the Git release but also a library or something.
Reply With Quote
  #17  
Old 1st April 2013, 07:29 AM
zilmar zilmar is offline
Core Team
Alpha Tester
Project Supporter
Administrator
 
Join Date: Jun 2005
Posts: 987
Default

yer I am not sure ....

this is what I get.
Code:
D:\bug>git --version
git version 1.7.11.msysgit.1

D:\bug>git clone http://pj64-emu.com:8090/project64.development/ project64
Cloning into 'project64'...
remote: Counting objects: 6211, done.
remote: Compressing objects: 100% (3157/3157), done.
remote: Total 6211 (delta 4879), reused 3995 (delta 3032)
Receiving objects: 100% (6211/6211), 27.28 MiB | 336 KiB/s, done.
Resolving deltas: 100% (4879/4879), done.
Checking out files: 100% (565/565), done.
maybe there is something I have done wrong with the setup. Not Sure
Reply With Quote
  #18  
Old 1st April 2013, 08:00 AM
Mr. DOS Mr. DOS is offline
Junior Member
 
Join Date: Dec 2008
Posts: 4
Default

Client issue of some sort. I was able to clone the repo just fine from another machine.

And finally on-topic, thanks so much for deciding to release the project source again. I hope it pays off for you in terms of new contributors, but even if it doesn't, the educational benefit of being able to peek inside the guts of an emulator such repute as Project64 is incredible.
Reply With Quote
  #19  
Old 1st April 2013, 08:28 AM
zilmar zilmar is offline
Core Team
Alpha Tester
Project Supporter
Administrator
 
Join Date: Jun 2005
Posts: 987
Default

Quote:
Originally Posted by Mr. DOS View Post
Client issue of some sort. I was able to clone the repo just fine from another machine.
I am glad you got it working, cause I was not sure how to fix the problem

Quote:
Originally Posted by Mr. DOS View Post
And finally on-topic, thanks so much for deciding to release the project source again. I hope it pays off for you in terms of new contributors, but even if it doesn't, the educational benefit of being able to peek inside the guts of an emulator such repute as Project64 is incredible.
if you compare the original source of the main emulator to this version you will see the code is very different. A lot more cleaner and easier to manage. Hopefully you able to learn something off it.
Reply With Quote
  #20  
Old 1st April 2013, 01:18 PM
MarathonMan's Avatar
MarathonMan MarathonMan is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Jan 2013
Posts: 454
Default

Also managed to clone successfully. Thanks for putting the source out there, Zilmar.

Was this announced? I thought the source was staying closed?
Reply With Quote
Reply
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 07:38 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.