Go Back   Project64 Forums > Public Version > Project 64 - v2.x - Issues

Reply
 
Thread Tools Display Modes
  #1  
Old 29th October 2018, 07:29 AM
nietzsche666 nietzsche666 is offline
Junior Member
 
Join Date: Oct 2018
Posts: 3
Default Severe issues with switching between rumble & mem paks

I just recently got into N64 emulation and stuck with project64 2.3.2.202 so far.

Some essential feature somehow refuses to work on my system (Win1064, NRage for PJ64 2.5.2.202 input plugin).

Switching between mem pak and rumble pak on the fly messes up in multiple ways (I know I have to wait for switching paks until the game tells me to, so bad usage of the switch function isn't the problem here):

First of all, after setting a custom key for MemP < -- > RumbleP, after starting a game nothing will happen using that hotkey, unless I again open the controller plugin settings and click "use" in the hotkey tab. I'm not sure if I forgot to check another setting somewhere, but I would of course like the hotkey to work by default.

Now, even if the little boxes show up after this (for switching paks /Pak changed to Rumble Pack), the problems won't stop.

So far, I can get rumble working mostly when I start a game with rumble pak set to default. But when I start with mem pak default, I can switch the paks on the fly, the game will give info about detected rumble pak, but the gamepad will just not rumble.

Some games need the mem pak set to default to get save working or to even start up (Vigilante 8), so I will just not be able to have rumble in those specific games. Usually, even if it works with rumble default, many games tend to give me more annoying nag screens when starting up.

In Rampage World Tour, I can get rumble by setting rumble to default and only switching to mempak manually afterwards when asked to do so in enabling autosave or restore. But if I use the hotkey for switching when asked, rumble will again not work. I have to switch the tab in the controller config and click "use" for this to work.

In Mupen64Plus (incl. GLideN64-GUI) there is a similar "on the fly" - function that seems to work better in almost all (not all) cases. But I really would like to continue using Project64, less crackling sound, better cropping to 4:3 etc.

DId I forget some setting to make this work? Is the current official build broken regarding pak switching?

If this problem has been discussed before, I'm sorry. I browsed the forum for a while but didn't find anything.
Reply With Quote
  #2  
Old 29th October 2018, 01:46 PM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 2,653
Default

I'd say your best bet is to post here (probably just copy most):

https://github.com/project64/project64/issues

not many people the can do anything about visit these forums anymore.
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
Reply With Quote
  #3  
Old 29th October 2018, 08:08 PM
nietzsche666 nietzsche666 is offline
Junior Member
 
Join Date: Oct 2018
Posts: 3
Default

Thanks for the link. I will post the issue over there.

I'm curious, though, does anyone else have the problem I described?


Maybe I can narrow it down to some weird system issues on my part if this is usually working correctly for most Pj64 users.
Reply With Quote
  #4  
Old 29th October 2018, 08:39 PM
nietzsche666 nietzsche666 is offline
Junior Member
 
Join Date: Oct 2018
Posts: 3
Default

Found out something about the first problem (Pj64 not recognizing the switch hotkey) by now.

The hotkey works fine by default and will trigger those little info boxes confirming the switch if the gamepad is not set to xinput at the start. Only if Xinput is checked, the hotkey won't do anything until I click "use" at the controller settings. (This doesn't change anything about the follow-up problems I described, though.)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 08:26 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.