Go Back   Project64 Forums > General Discussion > Open Discussion

Closed Thread
 
Thread Tools Display Modes
  #441  
Old 20th October 2013, 04:38 PM
shunyuan's Avatar
shunyuan shunyuan is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2013
Posts: 491
Default

Quote:
Originally Posted by Marcelo_20xx View Post
I had installed the latest DirectX update for Windows XP which is 9.0c June 2010, also latest VC Redist for 2005 2008 and 2010 to rule that out...

UPDATE: The plugin rarely crashes under Windows 7 64 Bits

UPDATE 2: It crashes if I press reset (F1) in the emu too...
I still can't reproduce the crash on my computer.

Did you have any error dialog before the crash, the screen shot of error dialog may help?
__________________
---------------------
CPU: Intel U7300 1.3 GHz
GPU: Mobile Intel 4 Series (on board)
AUDIO: Realtek HD Audio (on board)
RAM: 4 GB
OS: Windows 7 - 32 bit
  #442  
Old 21st October 2013, 11:12 PM
Marcelo_20xx's Avatar
Marcelo_20xx Marcelo_20xx is offline
Senior Member
 
Join Date: Oct 2013
Posts: 171
Default

No errors shows when the plugin causes a hang or a crash, the worst offender is 1964, if I use your plugin with this emu, I totally get my system hanged and need to hard reset the PC , its a damn shame since your plugin is really awesome, I haven't encountered any glitches so far on the 13 games I tested this past weeks.

Worth to note is that the plugin works fine under PJ64 2.X versions, maybe its your implementation of Zilmar's 1.1 interface?

Also coupled with Iconoclast/Batcat's RSP plugin N64 emulation never have been so good before, so thanks to both of you guys!

Last edited by Marcelo_20xx; 21st October 2013 at 11:17 PM.
  #443  
Old 22nd October 2013, 06:32 PM
shunyuan's Avatar
shunyuan shunyuan is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2013
Posts: 491
Default

Quote:
Originally Posted by Marcelo_20xx View Post
No errors shows when the plugin causes a hang or a crash, the worst offender is 1964, if I use your plugin with this emu, I totally get my system hanged and need to hard reset the PC , its a damn shame since your plugin is really awesome, I haven't encountered any glitches so far on the 13 games I tested this past weeks.

Worth to note is that the plugin works fine under PJ64 2.X versions, maybe its your implementation of Zilmar's 1.1 interface?

Also coupled with Iconoclast/Batcat's RSP plugin N64 emulation never have been so good before, so thanks to both of you guys!
I can't reproduce the crash on 1964 either, but 1964 v1.1 will hang for some specific games such as RR64, no matter witch gfx or audio plug-ins used.

can you share your computer spec for reference? if I can't reproduce the hang or crash on my computer, it is hard to figure out what causes it.
__________________
---------------------
CPU: Intel U7300 1.3 GHz
GPU: Mobile Intel 4 Series (on board)
AUDIO: Realtek HD Audio (on board)
RAM: 4 GB
OS: Windows 7 - 32 bit

Last edited by shunyuan; 22nd October 2013 at 06:34 PM.
  #444  
Old 22nd October 2013, 07:52 PM
Marcelo_20xx's Avatar
Marcelo_20xx Marcelo_20xx is offline
Senior Member
 
Join Date: Oct 2013
Posts: 171
Default

My specs are:
Processor: Q9660 Intel Core 2 Quad
Motherboard: Intel DP45SG
Graphics Card: Asus Nvidia 9600GT
RAM: 2GB Corsair
OS: Windows XP SP3 32Bits
  #445  
Old 7th December 2013, 10:40 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

AHA! Now I remember.

Seems I was semi-wrong about this plugin being based *directly* on zilmar's Basic Audio Plugin.

It actually was based on 1964AudioLLE, which used zilmar's DirectSound code. (Much like 1964VideoLLE uses zilmar's DirectDraw code from his Basic CFB Plugin.) That explains the slight differences in his source from zilmar's.

No wonder he was so defensive about it being based on another audio plugin when I thought it had been zilmar's.
I'm welcome to him denying this again, btw, but we've already all seen him lie before at least once, so we won't argue with liars.

I think I'm done posting emulation-related shit on this forum. I was hoping this board would serve useful for proactive, academic discussions, or at least user testing, but instead, anything educational I have to say here, is competed against by people who just want to attract zilmar's attention of including their plugins into Project64 officially. I think it's safe to say, then: I'm the odd one out of this crew of developers. Never had anything to do with Project64, never will, and never want to.

Too many competitive developers, not enough influenced thinkers.
  #446  
Old 8th December 2013, 05:29 PM
the_randomizer's Avatar
the_randomizer the_randomizer is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Sep 2008
Location: USA
Posts: 1,136
Default

Quote:
Originally Posted by BatCat View Post
AHA! Now I remember.

Seems I was semi-wrong about this plugin being based *directly* on zilmar's Basic Audio Plugin.

It actually was based on 1964AudioLLE, which used zilmar's DirectSound code. (Much like 1964VideoLLE uses zilmar's DirectDraw code from his Basic CFB Plugin.) That explains the slight differences in his source from zilmar's.

No wonder he was so defensive about it being based on another audio plugin when I thought it had been zilmar's.
I'm welcome to him denying this again, btw, but we've already all seen him lie before at least once, so we won't argue with liars.

I think I'm done posting emulation-related shit on this forum. I was hoping this board would serve useful for proactive, academic discussions, or at least user testing, but instead, anything educational I have to say here, is competed against by people who just want to attract zilmar's attention of including their plugins into Project64 officially. I think it's safe to say, then: I'm the odd one out of this crew of developers. Never had anything to do with Project64, never will, and never want to.

Too many competitive developers, not enough influenced thinkers.
Yeah, and I bet my stupid posts probably contributed to your anger/annoyance
__________________
My rig:
CPU: Intel Core i7 4470 3.4 GHz to 3.9 GHz
Video card:: MSI nVidia GTX 970 4 GB GDDR5
OS: Windows 7 Professional 64-bit
RAM: 16 GB DDR3 SDRAM 10600
HDD: 2 x Western Digital 1 TB HDDs
Monitor: 23" Asus Full HD LED

Oh, and Snes9x > Zsnes in every way
  #447  
Old 9th December 2013, 01:02 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Maybe in the sense that you were yet another victim on this forum, to selfish developer capitalization, who fell for this bull shit.

But don't slap yourself over it. Don't think of it as though I'm done with my artistic passions for engineering or anything; I'd just really prefer to conduct my research and essays on a forum where I had more control than this. And I DON'T mean zilmar making me a moderator; that would just feed his ego or something if I let him do that. The only reliable solution seems to be some other forum.

And sure, some other things you may have said that came cross as incredibly optimistic and/or naive, also trigger my ticks, and I get very cynical and pessimistic over lots of trivial things. But sometimes, it's the smallest things that help shape our decisions for the better, not only those major factor which even half of the naked eye can understand. That's part of why major things seldom piss me off, compared to minor nitpick things. (The other part is just me being an ass, but that's another chapter.)

Just so you know I haven't made any real effort to fix the one and only reported RSP bug yet. Been relaxing my ass off watching anime.
  #448  
Old 22nd December 2013, 05:27 PM
Whiteknight17 Whiteknight17 is offline
Junior Member
 
Join Date: Dec 2013
Posts: 3
Default SIMPLE QUESTION :cool:

HELLO, I WOULD LIKE TO KNOW IF THE SOUND IS BETTER QUALITY WITH


STEREO + XAUDIO2 UPMIX ( BOTH OPTIONS TICKED )



OR ONLY XAUDIO2 UPMIX ( ONLY 1 ON 2 OPTIONS TICKED )



ALSO, yes i am using xaudio2 for sound driver.





CAN someone answer me !?????????????!!!!!!!!!!!!?!?!?

Last edited by Whiteknight17; 23rd December 2013 at 05:40 PM.
  #449  
Old 22nd December 2013, 07:14 PM
et500 et500 is offline
Project Supporter
Senior Member
 
Join Date: Sep 2008
Posts: 113
Default

Whether this plugin was initially based on other work or not, it has become the best audio plugin available on any N64 emulator.
  #450  
Old 22nd December 2013, 10:50 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Wouldn't be the first time you were wrong about something.
Constant optimists tend to have that problem.


For example, did you know that this plugin is the ONLY XAudio plugin for N64 emulators?
That's why it sounds so great. I never said it doesn't SOUND the best on most N64 emulators. (You're forgetting Nemu64. LaC's audio is still the most compatible and sounds better.)

Shunyuan's XAudio implementation is actually pretty decent. I'm not denying that.
But like the typical optimist in every single post you make on this forum in the middle of a pessimistic debate between other people, as usual, you're missing the point.

Besides, Jabo's DirectSound and Azimer's both sound better than this plugin in DirectSound mode. I don't use XAudio yet.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 03:13 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.