Go Back   Project64 Forums > Public Version > Project 64 - v2.x - Issues

Reply
 
Thread Tools Display Modes
  #1  
Old 7th May 2017, 08:09 PM
dafamily dafamily is offline
Junior Member
 
Join Date: Mar 2017
Posts: 16
Default Sync to Audio option Makes Games Sound Crackling!!

Hey guys,

When trying the Virtual Pro Wrestling 2 game I get 52fps normally when I disable the "Sync to Audio" option it I get 60fps but then the sound starts to crackling, with this option checked I have the sound problem fixed but I'm back to 52 fps!!

I've tried disabling the "Fixed Audio Timing" and that works but when the camera moves around I get 40 fps but the sound is fine!!

Any ideas guys,

Thanks for the help.
Reply With Quote
  #2  
Old 8th May 2017, 07:18 AM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,895
Default

the audio engine runs at the correct framerate for your rom region.
__________________
Xfire Profile | VBA-M | XBCD 0.2.7

CPU:Intel i7 920 @ 3.8(D0), Mainboard:Asus Rampage II Gene, Memory:12GB Corsair Vengeance 1600
Video:EVGA Geforce GTX 680+ 4GB, Sound:Creative XFI Titanium Fatal1ty Pro, Monitor:BenQ G2400WD
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
Reply With Quote
  #3  
Old 9th May 2017, 12:25 AM
theboy181's Avatar
theboy181 theboy181 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2014
Location: Prince Rupert,British Columbia Canada
Posts: 418
Default

Are you saying his region runs at 52 fps?

I have seen a few games where sync to audio does this. What I have been doing lately is using Vsync in my video plugin then unlocking the frame limit. Another thing to try is another audio plugin. The areas of the game where you get 40FPS are probably normal, you just want to make sure you don't go below 60Vi's

What plugins are you using?
__________________
So you think you can TECH!! Watch this!! https://www.youtube.com/watch?v=NAUKPq5QjL0

Last edited by theboy181; 9th May 2017 at 12:32 AM.
Reply With Quote
  #4  
Old 9th May 2017, 01:34 AM
dafamily dafamily is offline
Junior Member
 
Join Date: Mar 2017
Posts: 16
Default

Here is my setting for the emulator:

http://imgur.com/a/kv9DB

I also have BGM volume set to low as well and it still gives me the crackling sound!! Funny thing is that I've tried it on a different computer using Project64 2.3 with the same settings and the rom works fine!!
Reply With Quote
  #5  
Old 10th May 2017, 06:32 PM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 828
Default

Try my build of Azimer's 0.7. Put it in Project64\Plugin\Audio.

https://www.dropbox.com/s/czgzz9z14e...Audio.dll?dl=1

Try the option Disable AudioThread Sleep.
Reply With Quote
  #6  
Old 13th May 2017, 07:26 PM
dafamily dafamily is offline
Junior Member
 
Join Date: Mar 2017
Posts: 16
Default

I've just tried it on Project64 1.7 and it works!! Here is my settings if you guys are having the same issue:

http://imgur.com/a/hxEX0

Thanks for the help guys!!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 12:04 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.