#1  
Old 1st October 2017, 12:15 AM
americanzi americanzi is offline
Junior Member
 
Join Date: Oct 2017
Posts: 3
Default Paper Mario 64 Pro Mode issues

Hello,

I'm having a few issues with running PM64 Pro Mode.

Pro Mode is basically just a mod/hack that increases the difficulty of Paper Mario 64.

I'm having an issue booting the game through P64, and I'm also having an issue configuring my Dualshock 4 controller.

With Pro mode came these instructions:

-Get a US ROM for Paper Mario v1.0 and download Paper Mario Pro Mode above.

-Extract the zip file and run Star Rod Patcher.jar.

-Select the Paper Mario ROM and the .mod file and click "Create Modded ROM". This will give you two files: a new ROM for Paper Mario Pro Mode and a text file with Project64 emulator settings in it called "Project64 Settings.txt".

-Install Project64 and go to its Config folder. Find the file named "Project64.rdb".

-Copy the text from "Project64 Settings.txt" into "Project64.rdb" and save.
Download the GLideN64 video plugin. Copy the files in the zilmar folder to /Plugin/GFX/ for Project64.

-Launch Project64, use the GLideN64 video plugin we just installed, and load the modded ROM.


I'm getting the following errors while trying to boot:


Unhandled r4300i opcode at: 8006r754 Stopping Emulation!

Fatal Error: Stoppiing Emulation


After that, Project64 crashes.

I followed the directions to the tee, I'm wondering if I might have a file in an odd location or something.. I'm not very experienced with this stuff.



As for the PS4 controller issue:

I've downloaded DS4windows, updated the drivers, and the touchpad is working perfectly as a secondary mouse, but when I try to configure and use it in the normal Paper Mario 64, none of the configured buttons are doing anything. I've tried switching the plugins, restarting the rom, and using different controller ports through the settings.

I'd really appreciate any help!

Last edited by americanzi; 1st October 2017 at 12:20 AM.
Reply With Quote
  #2  
Old 1st October 2017, 02:13 AM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 828
Default

Further in the instructions it has this note:

Quote:
Opcode error when trying to boot game: you need to increase the RAM limit. If using Project64, make sure you updated the emulator's RDB config to include the mod.
You may not have updated the rdb correctly. Best to copy the contents of Project64 Settings.txt at the end of the RDB file.

Enabled advanced mode in Project64 settings. And right-click the mod in the rom browser, select edit game settings. Check that Memory size is set to 8MB.
Reply With Quote
  #3  
Old 1st October 2017, 04:28 AM
americanzi americanzi is offline
Junior Member
 
Join Date: Oct 2017
Posts: 3
Default

Quote:
Originally Posted by Frank74 View Post
Further in the instructions it has this note:



You may not have updated the rdb correctly. Best to copy the contents of Project64 Settings.txt at the end of the RDB file.

Enabled advanced mode in Project64 settings. And right-click the mod in the rom browser, select edit game settings. Check that Memory size is set to 8MB.


I did past the settings file at the end of the RBD.

As far as updating the RAM goes, I'm having trouble doing that as well. I see an option for it as soon as standard edition Paper Mario 64 boots up in the settings, but I can't even get to the title screen with the mod. I've scoured the settings when not in game and I'm not seeing an option to change the RAM.
Reply With Quote
  #4  
Old 1st October 2017, 01:22 PM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 828
Default

Options > Settings...
Uncheck Hide advanced settings. Click OK.
Right-click ROM in ROM browser.
Select Edit Game Settings.
Memory size is at the top on the right. Set it to 8MB. Click OK.
Start ROM.
Reply With Quote
  #5  
Old 3rd October 2017, 02:58 AM
americanzi americanzi is offline
Junior Member
 
Join Date: Oct 2017
Posts: 3
Default

Quote:
Originally Posted by Frank74 View Post
Options > Settings...
Uncheck Hide advanced settings. Click OK.
Right-click ROM in ROM browser.
Select Edit Game Settings.
Memory size is at the top on the right. Set it to 8MB. Click OK.
Start ROM.
I was using a more modern version of P64. I installed 1.6 and now the rom is booting fine.

Another issue is popping up and there are black bars/distortion on the screen every so often like a fuzzy channel on a CRT TV.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 05:40 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.