Go Back   Project64 Forums > Public Version > Project 64 - v1.6

Reply
 
Thread Tools Display Modes
  #1  
Old 20th February 2009, 03:25 PM
koippis koippis is offline
Junior Member
 
Join Date: Feb 2009
Location: pori,finland
Posts: 3
Question Problems with goldeneye and perfect dark

In pj64 1.6 Perfect Dark works fine at least on two first levels,after that it crashes when I choose accept or abort ofthe next mission(music goes on and loding picture stays but nothing happens,unless I end emulation and start again).This happens after every level after that..In goldeneye music is really choppy.(sky and water in frigate level is missing,sky is missing in PD too but that does not bother me)When I got to st Petersburg game started to have a lot of slowdown.I still passed it,but in the beginning of the archive level after cutscene it completely black out.Only way to end it was the taskmanager.
I used jabos,windowed 640x480.full screen 1280x1024 16 and 60 hZ.
FSS Transfer memory.Afiltering 2x.FSA 2x
My system specs
OS:Windows XP Home Edition (5.1. Build 2600) Service Pack 3
AMD Processor model unknown,MMX,3DNow(2 CPUs),~2.1GHz
Memory:2048MB RAM Page file 410MB used,3528 available
DirectX 9.0c(4.09.0000.0904)
NVIDIA GeForce 8600 GT,Integrated RAMDAC,Display memory 256.0MB
Current mode:1280x1024 (32bit) (60Hz)
Monitorlug and play(BENQ FP93G)monitor max res 1600.1200
Driver name:nv4_disp.dll
Driver version:6.14.0011.7519 DDI Version:9 (or higher)
Sound:Realtek HD Audio Output. Version:5.10.0000.5506, HW Accel level
-standard
Reply With Quote
  #2  
Old 20th February 2009, 04:23 PM
CA5 CA5 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Dec 2008
Posts: 199
Default

Quote:
Originally Posted by koippa View Post
In pj64 1.6 Perfect Dark works fine at least on two first levels,after that it crashes when I choose accept or abort ofthe next mission(music goes on and loding picture stays but nothing happens,unless I end emulation and start again).This happens after every level after that..In goldeneye music is really choppy.(sky and water in frigate level is missing,sky is missing in PD too but that does not bother me)When I got to st Petersburg game started to have a lot of slowdown.I still passed it,but in the beginning of the archive level after cutscene it completely black out.Only way to end it was the taskmanager.
I used jabos,windowed 640x480.full screen 1280x1024 16 and 60 hZ.
FSS Transfer memory.Afiltering 2x.FSA 2x
My system specs
OS:Windows XP Home Edition (5.1. Build 2600) Service Pack 3
AMD Processor model unknown,MMX,3DNow(2 CPUs),~2.1GHz
Memory:2048MB RAM Page file 410MB used,3528 available
DirectX 9.0c(4.09.0000.0904)
NVIDIA GeForce 8600 GT,Integrated RAMDAC,Display memory 256.0MB
Current mode:1280x1024 (32bit) (60Hz)
Monitorlug and play(BENQ FP93G)monitor max res 1600.1200
Driver name:nv4_disp.dll
Driver version:6.14.0011.7519 DDI Version:9 (or higher)
Sound:Realtek HD Audio Output. Version:5.10.0000.5506, HW Accel level
-standard
Doubt if it'll help, but there's a new Directx out, as pointed ou by lynskey. Other than that - dunno. I'm sure Iconoclast or Squall will pop up 'n' help though

EDIT: Ignore this crap, that'll do sod all.

Last edited by CA5; 27th February 2009 at 08:21 PM.
Reply With Quote
  #3  
Old 20th February 2009, 11:32 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 14,889
Default

Increase the frequency if you can from 60 Hertz. This is the refresh rate for full screen display drawings. If it is low the risk of a black screen can happen.

The hang in memory after the first two levels has not been noted around here before. Try right-clicking Perfect Dark in Project64's list of installed games, choose "Edit Game Settings...", and set the self-modifying code method to Protect Memory. This should be the default setting for games...but it isn't. Well, not on Project64, at least.

Choppy display and audio often intertwine. Full screen mode is likely the cause of this, so try windowed mode or switching to other plug-ins. zilmar's No Sound plug-in and Jabo's Direct3D 6 are worth notetaking on.

"Doubt if it'll help, but there's a new Directx out, as pointed ou by lynskey."
Lynskey doesn't know what he's doing. The latest needed for emulation functions for this hardware is DirectX 8, but Direct64 plug-in uses DirectX 9 to draw.
Reply With Quote
  #4  
Old 22nd February 2009, 07:38 PM
koippis koippis is offline
Junior Member
 
Join Date: Feb 2009
Location: pori,finland
Posts: 3
Default

I got the golden eye work in windowed mode with protect memory.Its still slowing down and sound problem exist,but what comes to the sound I got used to it at least it doesnt crash.And even cheats doesnt crash it.It works if I dont use full screen.What comes to PD theres still problems in between the levels and in full.screen, also slowdowns.Often it doesnt load next level,only accept - decline screen and cheat using is a sure way to crash it between every level.According to taskmanager no other progresses running.I even removed my deskjet printer program(havent had bought ink in it long time anyways)closed the virus scanner and even pulled out the power cord from my internet modem.according to task manager there was only 33 applications and processor usage 0-1%.so probably not a system requirement issue?
Reply With Quote
  #5  
Old 22nd February 2009, 08:07 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 14,889
Default

Try changing setting Sync Game to Audio in the sound plug-in configuration (under Options). The sound should be choppy because of the low speed.
Also try Options: Settings...
Change the video plug-in to Jabo's Direct3D6 1.5.2 and the audio plug-in to No Sound. See if the speed counter at the bottom-right is about at 60 or if it's any better.

Cheats can frequently cause memory instability. If you have any consistent problems with playability in this aspect for Perfect Dark try using the interpreter.
If (Options: Settings...) Hide Advanced Settings is unchecked right-click the game in Project64's list of installed games, and choose "Edit Game Settings...". Change the core style to "Interpreter".
Reply With Quote
  #6  
Old 25th February 2009, 05:51 PM
koippis koippis is offline
Junior Member
 
Join Date: Feb 2009
Location: pori,finland
Posts: 3
Red face

its ok,I got them work as long as I dont use cheats
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 02:37 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.